IonCube Loader is a software tool, which is needed to run files that are protected with ionCube PHP Encoder. The aforementioned is an application used to make PHP code human unreadable, to protect it from reverse engineering and illegal use. Numerous script-driven applications, especially discussion boards, content management systems and electronic commerce solutions are encoded with ionCube PHP Encoder, therefore if you obtain a script and you find that ionCube is on the list of website hosting environment prerequisites, you need to make sure that your web hosting server has the instrument pre-installed. Though it is not that hard to set it up if you have your own server, it is close to impossible to do that on a shared web hosting server because the PHP environment will have to be precompiled and all clients on the server shall be affected.

IonCube in Cloud Web Hosting

IonCube Loader comes with all cloud web hosting packages that we provide, so every time you need it in order to set up and execute a script application that requires it, you can activate it with a click inside the Advanced area of the Hepsia Control Panel. Since you're able to switch the PHP release that is active for your account in the same section, you need to enable the instrument for every new version which you set. When you're more skillful, you're able to employ a php.ini file in a domain or subdomain folder and set both the PHP version as well as the status of ionCube Loader for that particular site only, without affecting the whole account. In this way you are able to run both new and older script apps for multiple websites inside the same account - something that you won't be able to do with a lot of other hosting service providers available on the market.

IonCube in Semi-dedicated Servers

In case you get a semi-dedicated server package from us, you'll be able to take advantage of any kind of script-driven app which requires ionCube Loader due to the fact that the tool comes with all of the servers that are part of our revolutionary cloud web hosting platform. In addition, we support multiple releases of PHP, which means that if you move from PHP 4 to 5.2 or 5.3, for example, you can enable ionCube for that particular version with just a click from your Hepsia Control Panel. Our platform will remember your choice, and if you switch back to the previous release of PHP, the tool will already be active. For more tech-savvy users, we also offer the option to choose the PHP version and whether ionCube will be active or not for a particular domain without altering the settings for the whole web hosting account. This is done by putting a php.ini file within a domain folder with several lines of program code.